CPAN Testers is only made possible with the support of our sponsors.
For more information on sponsoring, please visit the I CPAN Testers website.

Upgrade Notice

The CPAN Testers Wiki site has been upgraded since you last accessed the site. Please press the F5 key or CTRL-R to refresh your browser cache to use the latest javascript and CSS files.

CPAN + CPAN::Reporter Hints and Tips

(discuss firewalls and workarounds)

Getting perl-5.00505 to work with CPAN::Reporter

Some notes on necessary modules, patches, and workarounds, as of October 2007:

  • A rough log of my module installation steps
sudo perl5.00505 -MCPAN -eshell
install CPAN

Warning: something in this process sets the mode of /tmp to 0700! Restore the original mode as soon as possible!

perl5.00505 -MCPAN -eshell
install TJENNESS/File-Temp-0.16.tar.gz

Setup a distroprefs file for File::Copy::Recursive, ot apply the RT patch manually. The distroprefs file may be found as DMUEY.File-Copy-Recursive.yml in the distroprefs subdir of the CPAN.pm distribution.

install File::Copy::Recursive
install Term::ReadKey
install Term::ReadLine::Perl
install RGIERSIG/Expect-1.15.tar.gz
install ExtUtils::MakeMaker
install CPAN::Reporter
  • Finally, the following modules are installed (version on my system in parenthesis)
    • CPAN (1.92_51 or 1.9203)
    • warnings::compat (0.04)
    • File::Temp (0.18 + patch on RT); TJENNESS/File-Temp-0.16.tar.gz works without a patch
    • Test::Reporter (1.36)
    • Net::SMTP (2.31)
    • Time::HiRes (1.9708)
    • Pod::Parser (1.35)
    • File::Copy::Recursive (0.35 + patch on RT); patch also on CPAN in ANDK/patches/File-Copy-Recursive-0.35-SREZIC-01.patch.gz
    • CPAN::Reporter (0.99_15)

If podlators-2.0.5 is installed, then you have to remove .../lib/5.00505/Pod/Text.pm from the core perl library, so that the version from site_perl is used. This is necessary because a newer .../bin/pod2text is also installed with podlators and needs also the current module version.

After this you can also install Module::Build 0.2807 (not the latest version).

The latest usable versions of some popular modules for perl 5.00505:

  • Tk 800.024
  • MIME::Base64 2.23
  • HTML::Parser 3.45
  • Digest::MD5 2.33
  • latest LWP has two test failures, but maybe these are rather harmless?
  • Expect 1.15
  • unfortunately neither YAML nor YAML::Syck pass tests with 5.00505, but one could use CPAN.pm distroprefs in the Data::Dumper format

Trying perl-5.00405 to work with CPAN::Reporter

makefile may require several modifications to compile perl. http://www.nntp.perl.org/group/perl.perl5.porters/2003/02/msg71859.html http://www.nntp.perl.org/group/perl.perl5.porters/2003/02/msg71862.html http://www.nntp.perl.org/group/perl.perl5.porters/2003/02/msg71860.html http://www.nntp.perl.org/group/perl.perl5.porters/2003/02/msg71869.html

Run CPAN: path/bin/perl -MCPAN -e"shell"

install G/GB/GBARR/Scalar-List-Utils-1.14.tar.gz (unless this ticked is resolved: [http://rt.cpan.org//Ticket/Display.html?id=31041])

Following problem stopped my attempt: recursive dependencies and many versions that support 5.4 are only on backpan.